A-A+

phpmanager安装opcache

2020年08月08日 Laravel, php, windows 暂无评论 阅读 223 views 次

安装composer提示需要opcache,已经在phpmanager开启了opcache却依然提示错误:

PHP Warning: PHP Startup: Invalid library (appears to be a Zend Extension, try loading using zend_extension=php_opcache.dll from php.ini) in Unknown on line 0

 

查看php.ini发现phpmanager开启opcache有问题:

phpmanager是在php.ini中添加了:

[PHP_OPCACHE]

extension=php_opcache.dll

这是错误的,正确的应该是:

zend_extension = php_opcache.dll

 

完整内容:

opcache.enable = 1

opcache.enable_cli=1

zend_extension = php_opcache.dll

opcache.memory_consumption=128

opcache.interned_strings_buffer=8

opcache.max_accelerated_files=10000

 

处理完毕后,发现依然提示错误:

PHP Deprecated: Directive 'track_errors' is deprecated in Unknown on line 0

 

在php.ini中修改

track_errors = Off

 

注意:phpmanager已经自动添加了track_errors = Off,所以有2行,修改phpmanager添加的那一行即可。

标签:

给我留言